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Introduction

The Synapse Server is the new generation seismic server software developed by IMS.  
The server handles:

• Coordination of telemetry between devices in the seismic network.  This includes:
◦ All IMS hardware (e.g. netSP's, NetADC's and intelligent UPS's etc.).
◦ ISSI GS-generation hardware.
◦ Compatible 3rd party devices.

• Association of triggers into events.
• Prioritisation of seismic data for transmission.
• Automatic processing of events.

The Synapse GUI interface provides useful tools to monitor, control and configure the 
seismic system:

• Monitor displays provide the operator with a live view of the seismic system's 
status

• System control functions are available to interact with devices in the seismic 
network

• Configuration tools provide wizards to create and modify seismic system settings

All of the above are provided as user friendly, graphical interfaces.

For experienced technical users, Synapse can also be monitored from a web browser.
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Installing Synapse Server

Download:

The Synapse server installers can be downloaded from:

http://software.imseismology.org/synapseserver/

Installers:

Linux 32 bit: e.g. synapse_server_installer_linux_i386_2011-09-01.zip
Linux 64 bit: e.g. synapse_server_installer_linux_amd64_2011-09-01.zip

Prior to installation:

Please have the following information ready before installing the Synapse Server:

1. The list of network id's that will be monitored by the Synapse Server, e.g. 23 24
2. The root path where IMS databases will be stored (please note that this path does 

not include the database names).  E.g. /data/ims
3. An alternative port number (e.g. 8004) if the default port number (8001) is not 

allowed by the IT department of the mine.

Follow these steps to install the seismic server software:

1. Unzip the installer:

unzip synapse_server_installer_linux_amd64_2011-09-01.zip

2. Install the Synapse Server:

cd synapse_server_installer_linux_amd64_2011-09-01
./install_synapse_server

3. If the installation completed without any error messages, Synapse should now be 
running.

4. Inspect Synapse Server settings by viewing the following file:

~/.ims/synapse_server/settings.properties

5. Check if the Synapse Server is running:

Point web browser to http://localhost:8001/ims-synapse

6. If no error messages are displayed in the browser, the server is up and running.

7. Add the keep_synapse_server_alive script to the cron.  This script ensures that the 
Synapse Server is running and starts the server when the PC reboots.
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crontab -e (and add the following two lines)

# Check that glassfish is alive. 
*/5 * * * *  /home/ims/synapse_server/keep_synapse_server_alive

3



Licensing Synapse Server

Each Synapse server has to be licensed for the number of channels that will be sending 
data to the server, as well as for the writing of seismic data to disk.
 
The server does not have to be restarted when a new license is introduced.

1. Request a license file from IMS
2. Copy the license file to:  ~/.ims/licenses

Updating Synapse Server

If the PC running the Synapse server can connect to the internet, new updates will be 
downloaded automatically.  If not, a new update must be manually copied to the PC.

Update Synapse by following these steps:

1. Copy the new ims-synapse-server.war file to ~/synapse_server
1. If the PC connects to the internet, copy ims-synapse-server.war from 

~/.ims/synapse_server/updates/serverwar/
2. cd synapse_server
3. ./update_synapse_server_war

Synapse Server Scripts

The Synapse Server scripts resides in ~/synapse_server.

• Start the Synapse Server:

./start_synapse_server

• Stop the Synapse Server:

./stop_synapse_server

• Restart the Synapse Server:

./restart_synapse_server

• Update the Synapse Server:

Copy the new ims-synapse-server.war file to ~/synapse_server
./update_synapse_server_war
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Installing the Synapse Graphical Interface

Download:

The Synapse server installers can be downloaded from:

http://software.imseismology.org/synapse

Installers:

Linux 32 bit: e.g. ims_synapse-2012-05-08-linux-amd64.sh
Linux 64 bit: e.g. ims_synapse-2012-05-08-linux-i386.sh
Windows 32 bit: e.g. ims_synapse-2012-05-08-windows-i386.exe

Follow these steps to install Synapse:

1. Install Synapse by running the installer

Synapse can now be launched from the IMS Synapse desktop icon.
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Updating Synapse

On startup, a balloon will indicate if updates are available.  Click on the link to update the 
application.

When the balloon disappears, it can be displayed by selecting the earth icon in the right 
hand corner.  Please note that the latest Synapse updates should be installed when 
available.
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Background Information

Databases and Network Id's

Each mine with a seismic network has a network id (in short netid) that uniquely identifies 
the mine.  In the following examples, our fictional mine has a netid of 23.

Each Synapse PC also has two databases containing seismic data:

• A database with automatically processed data or data processed by the mine 
(fictional database tst).

• A database with data processed by IMS processing services (fictional database 
tstIMS).

7



Running Synapse for the First Time

User Management

Introduction

As mentioned in the introduction, Synapse provides tools to monitor, control and configure 
the seismic system.  The Synapse user manager can be used to create and manage the 
users that will be administrating the Synapse seismic server.  Various roles can be 
assigned to each user, allowing them to perform certain tasks.  Currently the following 
roles can be assigned to each user:

1. Admin: An administrative user may perform any task in Synapse
2. Controller: The user may perform tasks related to the control of the system

(e.g. sending test pulses to the sites and updating hardware 
modules)

3. Configurator: The user may configure the system

A Synapse user without any roles defined may view the seismic system, but cannot 
perform any tasks.

An Admin user is created by default and can be used to perform any task.  Please note 
that the default password for the Admin user is:  Admin.  It is recommended that the 
password is updated, and individual users are created for administrating the Synapse 
system.

Creating New Users

To create new users on the Synapse server:

1. Log in as Admin user:  File → Login
2. Expand the Global Configs node in the tree

3. Right click on the Users node in the tree and select Manager Users.  If this option 
is not available, please ensure that Advanced Config Editing is enabled:
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1. Select Tools → Options from the menubar
2. Select the Con Editor tab
3. Enable:  Show advanced config editor options
4. Restart Synapse

Please not this option will be disabled if a user without Admin rights has logged in.

4. The User Manager window will be displayed
5. Select Add User

6. Enter the name of the user:

7. The user will be added to the list of available users
8. Select the user in the list on the left, and fill in the details and password of the new 
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user (demonstrated in example below)
1. Specify Roles by entering a space separated list.  More than one may be 

specified
2. Click on Reset Password to enter a new password

9. Click on Save User and OK

Once all the users have been added to the Synapse server, the client configuration files 
have to be synchronised with those on the remote server.  Please refer to 
trace-remote-database-and-configs-TRACE-DOC-REMOTE-201210-GGv0.pdf for more 
information.

Logging into Synapse

There are two ways for a user to log into Synapse:

1. If a control function is accessed and Synapse detects that a user is not logged in, a 
login dialog will be displayed prompting the user to log in

2. By accessing the File → Login menu option
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Specifying a Synapse Server

Synapse allows one to monitor, control and configure a Synapse Server.  Firstly, add a 
new Synapse Server (please note that this is a once-off procedure):

1. Select Window → Services
2. In the explorer window, right click on Servers and select Add new IMS Synapse  

Server
3. Enter the following:

1. Description:  Synapse
2. Hostname:  localhost (or the PC name / IP address of the Synapse Server)
3. Port:  8001

4. Open the properties window by selecting Window → Properties.  Move and dock 
the window in the left hand corner of the Synapse application.
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Monitoring

While monitoring, we would like to see what is happening inside the seismic system.
For example, which sites are triggering or are the system experiencing any problems.

System Viewer – Logical Layout
'
The System Viewer shows the logical layout of the seismic system and reports the 
connections between the netSP's, their netADC's and corresponding sites.  To view the 
System Viewer:

1. Expand the nodes in the tree (under the network id) and double-click on System 
Viewer.

2. The logical layout should now be displayed in the graphical window.
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Colour is used to indicate the status of the devices:

1. Red indicates a critical problem.
2. Orange indicates a warning or intermediate state.
3. Green indicates a system that is working well!

In the previous picture all the devices and sites are green which means that the system is 
in a good working condition.

Example:

In the next picture, the netSP with serial SL00002 is orange - it is restarting for some 
reason.  Site 2 is also orange indicating that it is configured to send data, but has not yet 
started to transfer data to Synapse.

13



By hovering the mouse over the site (or device), the current state is reported.
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Detailed View

In detailed mode, more information is displayed in the graphical view.

1. Select Display Detailed View in the System Viewer window.
2. By selecting a node (by double clicking), the properties of the node is displayed.

Example:

In the next picture the properties of the site is displayed.
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Issue Monitor

The Issue Monitor displays a list of issues currently experienced by the seismic system.

There are three issue levels:

Icon Message Type Description

Information Messages These are information messages reported by 
Synapse and does not have to be cleared

Warning Messages These are non-critical issues, but may indicate a 
problem with the system and should be investigated

Error Messages These are critical issues and must be resolved

Important note:  the aim is to clear all warning and error messages from the Issue Monitor.

Displaying Issues

The Issue Monitor can either display all issues reported by the system, or display a filtered 
list of issues that focusses on one device or site.  Double click on the Issue Monitor node 
in the tree to display the monitor containing all issues.  If a node (e.g. a site) has issues, an
Issue button (yellow exclamation mark icon) will be appear in the corresponding node.  
Select this button to show a filtered set of issues.
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Example:

In the next example, netADC NA110012 has an active issue button   At the bottom of the 
viewer the filtered list of issues are displayed.

The filtered Issue Monitor reports that there is a sensor connected to the netADC that does
not have a site defined.

Although the system is designed to be plug & play and runs with the minimum setup, one  
has to define sites as they specify the coordinates in the mine as well as triggering 
parameters.
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Resolving Issues

Issues with a tick mark next to the issue can be resolved with the help of a wizard.

1. Right click on the issue in the Issue Monitor
2. Select Resolve Issue
3. In this example the Site Wizard opens and guides us through the process of 

defining the missing site.
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Site Wizard

Step 1 – Start

Step 2 – Name and site coordinates
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Step 3 – Sensor Information

Step 4 – Complete process
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Step 5 – Site configured and displayed in System Viewer
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Displaying All Issues Reported by the Synapse Server

In the previous section, we have zoomed into issues found for a specific device (in this 
case a netADC with missing sites).  The following view shows us a list of all issues found 
by Synapse.  Some cannot be resolved automatically, but hints point us in the right 
direction in solving them.

Hints and Tips

Select the help button for more information on how to resolve the issue.
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Event Builder Monitor

The Event Builder Monitor displays the live status of trigger association and event building,
based on reported trigger times and received seismograms.  During the event building 
process:

• STA/LTA trigger times of sites are reported
• Trigger times associate to form events
• The associated triggers are prioritised for transmission:

◦ Associated, triggered seismograms sent first
◦ Non-associated, triggered seismograms sent next
◦ Un-triggered waveforms are sent last (bandwidth permitting)

• Events are available on disk as soon as seismograms arrive. Late seismograms are
post-associated and merged with existing events

The Event Builder Monitor can be accessed by following these steps:

1. Double click on the Event Monitor in the tree

2. The Event Monitor will open and a list of events will be displayed
3. Expand an event to display the triggers associated with the event
4. Click on a trigger node to display the corresponding waveform for the trigger

In the next example, a trigger from a blast is displayed:
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Configuration

Editing configuration files on the Synapse Server

When running the Synapse Server and the Synapse graphical interface on more than one 
PC, a set of configuration files must be available on each PC.  The configuration files are 
stored in ~/.ims/conf.  To edit the configuration files on the Synapse Server (most likely 
remote server), follow these steps:

1. Expand the Synapse server node in the tree
2. Expand the Netid node (e.g. 23)

3. Expand the tree to display the property nodes for the specific network.
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4. Edit properties by selecting the corresponding node.  For example, to edit the 
settings for the Automatic Processing server, select the Auto Processing Settings 
node from the tree.  If the properties are not displayed, ensure that the Properties 
window is open by going to Window → Properties and docking it into the 
bottom-left corner.
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5. By selecting a field, in this example the Minimum Number of Triggers field, a short
explanation is displayed at the bottom of the properties window.
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Opening the Con Explorer Window to edit the local configuration 
files

The Con Explorer Window also allows one to edit the configuration files on the local PC.  
Follow these steps to open the editor:

1. Select Window → Con Explorer
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2. The Con Explorer window should now be displayed.  Expand the tree to display the 
property nodes for the specific network.
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System Control

The main focus of System Control is to instruct the seismic system to perform various 
tasks.  For example, to test the sensor, a test pulse can be sent to the netSP.  All the sites 
connected to the netSP will respond by creating test pulses and sending it back to 
Synapse.

Please note that either an Admin user or a Controller must be logged in to perform 
system control functions.  If a control function is accessed and Synapse detects that a user
is not logged in, a login dialog will be displayed prompting the user to log in.  Please refer 
to the Running Synapse for the First Time → Creating Users section for more 
information.

To access various system control functions:

1. Right click on a device or a site.
2. Select on option from the popup menu.

In the next example, the control functions for the netADC are displayed.

30



System Control Options

Restart Software

Restarts the software on the device.

Perform Tap Test

During a tap test, the netADC checks if the X, Y or Z polarity in the sensor has been 
flipped.  If polarity is flipped, an issue will be raised and displayed in the Issue Monitor.

Display ATU History Graph

The ATU History Graph, plots the ATU period as received from the netADC's.  The 
expected ATU period is plotted as 'n single green line, with the ATU period (in seconds) 
from the netADC's plotted as dots on the graph.  There should be minimal deviation from 
the green line.

To display ATU graphs:

1. Right click on a netSP or netADC node in the System Viewer
2. Select Display ATU History Graph

The next example displays the ATU History for a single netADC.
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What is ATU (Analogue Time Update)?

It is absolutely essential to have common time between the different IMS Stations to be 
able to establish where a seismic event occurred. 

The IMS System makes use of a special break signal of specific length, to generate an 
ATU (Analog Time Update) signal that the IMS Stations will synchronize to. 

The ATU has higher priority than other transmitted data, and the IMS Station’s internal 
clock will be reset by the trailing edge of the ATU signal.  Data exchange between  the 
Synapse server and the individual IMS Stations, utilizes the TCP/IP protocol.  ATU is 
injected to the DSLAM and is conveyed to the dsl modems at each IMS Station.  The local 
dsl modem extracts this signal and passes it on to the IMS Station.  Every IMS Station will 
therefore receive the ATU signal at exactly the same time, thereby resetting their internal 
clocks, resulting in common time between IMS Stations.

It is imperative that the seismic stations have common time within less than five 
milliseconds of one another (higher accuracy may be required for smaller systems).

The timing circuitry in the IMS Stations makes use of a crystal. This crystal can drift over 
time causing it to oscillate at a different frequency, resulting in the IMS Station’s clock 
drifting.  This can be compensated for by changing a software value (Time Counter Value).
A marginal change in this value will rectify the drifting time of such an IMS Station.  The 
clocks in the IMS Stations are reset every five minutes.

A problem with the ATU's usually indicate a communication issue.

Display Issues

If the option is enabled, issues have been reported for the device or site.  Select this option
to display the filtered list of issues.
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Update Software Modules

The software running on the device can be updated via Synapse.  If a new update is 
available, a little green arrow will appear and the right click menu action will become 
active.

Step 1 – Look for updates marked with green arrows
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Step 2 – Apply Updates

In this example, the netADC has two packages that may be updated.  A package is 
selected and Synapse sends the new package with an update instruction to the netADC.
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Daily Routines

The sole purpose of these daily routines is to verify that the system is functioning to its full 
potential.  A target of 100% uptime should be aimed for.

The following has to be checked:

1. System Viewer

All devices and sites should be green.  Any orange devices should be investigated for 
potential problems.  Red devices have critical problems and must be attended to 
immediately.
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2. Issue Monitor

All errors must be investigated and resolved.  Warnings may indicate problems and could 
be resolved.  Information messages does not have to be cleared.
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3. ATU History

Check the ATU History for each netSP on the network.  To view the ATU History graph:

1. Right click on a netSP in the System Viewer
2. Select Display ATU History Graph
3. Repeat this for all netSP's in the viewer

The ATU period for each netADC in the graph should not deviate from the green line 
indicating the expected ATU period.  There should not be any gaps in the graph.
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4. Test Pulses

Test pulses are generated daily by the netADC's and are stored in the IMS database.  Test 
pulses should be evaluated daily.  Test pulses are marked with a yellow lightbulb in the 
Event Monitor window.

A test pulse for a triaxial geophone is displayed in the next picture:

Test pulses are best evaluated by viewing the data in Trace:
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5. Hardware Updates

IMS will send a notification via e-mail when new updates are available for the netSP's 
and/or netADC's.  The Issue Monitor will also report available updates for the hardware 
deveices.  Apply the updates to the appropriate devices.
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