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1 Introduction

This document describes how to use Trace to import raw data (seismograms recorded by IMS
stations) into an existing IMS database, post-associate and view these data. Additionally, the
process of exporting data into various formats is described.

2 Installing the required Trace Plugins / Add-Ons

2.1 New Trace Install

If you are installing Trace for the first time or re-installing, it is recommended that you install
Trace-Standalone which is a version of Trace pre-bundled with the necessary plugins/add-ons.
The 64-bit Windows and Linux versions are available for download at the following URLs:

e Trace-Standalone for Windows (64 bit)

e Trace-Standalone for Linux (64 bit)

2.2 Trace Add-Ons

Alternatively, you can install the Standalone System Configuration (Neuron) Add-On from the
Tools > Add-Ons menu of Trace, and the IMS Trace Extras ASCII Exports Plugin from the Tools
> Plugins menu.

2.3 Trace Plugins

Another method is to install all the individual Plugins via the Plugins window accessed via the
Tools > Plugins menu of Trace:

e Enable the following update centres using the Add button in the Settings tab of the Plugins
window (figure 1):

— "IMS Standalone" (http://updates.imseismology.org/standalone/updates.xml)

— "IMS Con Tools" (http://updates.imseismology.org/contools/updates.xml)

¢ Install Plugins from the Available Plugins tab of the Plugins window (use the Search bar
to filter):
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- "IMS Con Editor"

— "IMS Trace Standalone Core"

- "IMS Standalone Actions"

— "IMS Standalone Database GUI"

- "IMS Standalone Device Access"

— "IMS Standalone Legacy"

- "IMS Standalone Postassociator Core"
- "IMS Standalone Postassociator GUI"
— "IMS Device Access API"

— "IMS Trace Extras ASCII Exports"

— "IMS Trace Extras Standalone Data Import"
— “IMS Trace Extras Continuous”

— “IMS Trace Extras Seismogram Tree”

Updatesl.ﬂ:-,-'ailable Plugins (136)'Do-.*.-nloaded Installed (229) | Settings

Configuration of Upcate Cernters. =S earch for available plugins

Active Name

— IMS Trace Standalone Update Center Remove
&) 4y M5 Con Tools Update Center
&~ i IM5 Core Customer Reports Update Ce..| | | 2ck check: 1/08/18 5:07 PM
& i IMS Core Suite Update Center URL:
] ifip IMS External Libraries Update Center het X - -
4 D://updates.imseismology.org/standalone/updates.xml
&) P IM5S Trace Extras Update Center _
] @i IMS Trace Mechanism Update Center
& i IMS Trace Services Extras Update Cent...
M #f IMS Trace Standalone Update Center
&) @i} IMS Trace Standalone Update Center
&  {fIMS Trace Update Center
& i NetBeans Platform Sl 3D
Add update centres o)
Automatically Check For Updates P
Check Interval: |Every Month Proxy Settings
Advanced
Plugin Install Location: |Default v
Close | |Help

Figure 1: Plugins window can be used to configure update centres (Settings tab), search for and

install plugins (Available Plugins tab).
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3 Importing raw data into an IMS database

Importing data recorded to removable media by IMS stations can be done with the following steps:

1. Optionally (but recommended), copy all the raw data to a single working directory on the
processing computer:

(a) create a directory at a convenient location on the processing computer (i.e. the com-
puter running Trace)

(b) copy the data directory (raw data) from each IMS Station’s recording media into the di-
rectory created in the previous step; select “Yes to all” if asked to merge files/directories
with the same name'

2. If a destination IMS database does not exist, create one using the File > New > Create New
Database menu item in Trace

3. Import the raw data into the destination IMS database:

(a) right click on the database created in step 2 (or open another existing database using
the File > Open > Database menu option) and select Import IMS Seismograms

(b) browse to, and select the directory containing all the raw data - this is the data di-
rectory created on an IMS station’s external recording media (USB flash drive) or the
consolidated directory recommended in step 1 above

(c) if asked about which target bucket(s) to import data to, you can accept the defaults
(empty)

(d) click OK and a progress bar should appear on the bottom right status bar, depending on
the amount of data, importing data can take quite some time; when completed a window
will pop up summarising the amount of data (number of seismograms) imported

4 Post-associating the imported (triggered) data

Before post-associating data, ensure that all configuration files (sites, sensors, adc’s) that were
used to configure the sites/stations in the field are present on the local computer running Trace.
If different computers are used, this means synchronising config files between the computers
(e.g. using Trace’s Tools > Downsync configs from menu item, or copying the files between
computers).

'Files from different recording stations should contain a unique path but may have some top level directories in
common, e.g. data/trig.
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Data imported from IMS stations will not be associated into events, thus if events are needed a
post-association process will be required. If only continuous data is required, then post associa-
tion is not required and you can skip this section. To post-associate triggered data:

1. Right click on the IMS database and select Post-Associate from trig.

2. Use the Wizard to edit the post-association parameters if necessary (see figure 2). Once
completed, click Finish to start post-associating data.

e This will cause the post-associator to consider all seismograms in the trig bucket (direc-
tory) of the database, including newly imported triggered seismograms as per section
3, for association into new (and optionally existing) events.

e Depending on the amount of data, the post-association process can take some time.
Once complete a summary information window will be displayed.

e Any events updated/created by the post-association process should now be visible
in the IMS database. You may need to refresh the database by right-clicking on the
database and selecting Refresh, or by closing and re-opening the database.

Steps

Associator Settings

1. Welcome
2. Associator Settings
3. TimeRange

Global Association Level

30 E
Travel Time Factor (alpha)

12 B
Travel Time Tolerance (beta) [s]

01|z E
® Merge events with existing events in target database?
Target Bucket
assoc
& Copy non-associated seismograms

Associationusing & trigger times maxirurm amplitudes

® Recalculate engineering parameters For resulting trigger records (allows filtering)

<Back | [INexE= | Cancel

Figure 2: The post-association wizard prompts for various event association parameter settings.
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5 Viewing Continuous Data

Before viewing data, ensure that all configuration files (sites, sensors, adc’s) that were used to
configure the sites/stations in the field are present on the local computer running Trace. If different
computers are used, this means synchronising config files between the computers (e.g. using
Trace’s Tools > Downsync configs from menu item, or copying the files between computers).

1. To view seismograms in the database tree (the default is to only show events):

e right click on the database and select the Properties menu item

e inthe Seismograms tab add t rig (for triggered) and unt rig (for continuous/untriggered
data) to the Buckets parameter as a comma separated list, e.g. this should read

assoc,trig,untrig
¢ in the Advanced tab enable Show Seismograms
¢ in the Tools tab select PER_HOUR for the Day Display parameter

e close the database properties window and refresh the database by right clicking on the
database and choosing refresh (or close and reopen the database)

2. Expand the IMS database tree and browse to a date/time node of interest - see figure 3.

3. Right click on a data/time node and select Open Continuous View. Use the controls bar
and navigation keys/mouse actions to navigate and alter the view (e.g. pan, zoom, en-
able/disable sites/components, etc.) - see figure 4.

File Edit Event Data Processing Tools Window Help

oH B@d B 0
Databases x| Servers ConEditor (Local) El @ Seismograms *

g aKea ks N O DmBY P S ¢
v B testskbd

[N lection (Experimental)

Live FFT | Inforgl=J&ft
[E]

testskb4
01 Aug 2018

Figure 3: Opening the continuous view.
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File Edit Event Data Processing Tools Window Help
oH BHA B O

Databases x| Servers Con Editor (Local) El @8 Seismograms X | @@ Continuous % JNTET 1A fmF

I . - - —

g@dKeahks= Bh e H3 3o asse B E @ | K <>

v & testskba SteSz6 Scake = 1.000E-05 v, 5066601 re~2

v 2oe Length = 300.000 5
v (J 23:00

"7 Controls bar —

» (J 13:00
e (] 19:00
Live FFT | Information x

Continuous Browser
= Visible:
@ 5minutes 0 seconds 0 milliseconds
© 2018/08/01 15:00:00.000000 - 2018/08/01
15:05:00.000000

® Sites: 1-21, 23-54, 102, 200, 201, 222 and 2017-2030

> ] 20:00
v (J 21.00

v (J 22:00 Site 2030X A

Site 2030 A

Site 2020Z A

Status Bar: move mouse here

for navigation key help \
20180801 1500000 - 15:05: 00
S

Figure 4: Continuous view showing controls and status bar.

6 Exporting Data

Should data be required for analysis outside of Trace, various export options are available.

Before exporting data, ensure that all configuration files (sites, sensors, adc’s) that were used to
configure the sites/stations in the field are present on the local computer running Trace. If different
computers are used, this means synchronising config files between the computers (e.g. using
Trace’s Tools > Downsync configs from menu item, or copying the files between computers).
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6.1 Event Data

Events can be exported in a few different ways? (e.g. catalogue data, events only, triggers only,
events and triggers, etc.) into a number of different formats. To export an event in Trace, right click
on the event (or time range) in the Database explorer pane and select one of the options below
the Export menu item as per figure 5.
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Figure 5: Exporting event data in Trace.

6.2 Continuous Data

Continuous data can be exported for time ranges of one hour or more.

Eneray [J] |

e To export continuous data in Trace, right click on a time range of interest in the Database
explorer pane and select the Export Continuous ASCIl Seismogram menu item (as per
figure 6), after which you will be prompted to:

— choose a destination directory where the ASCII data will be exported to

2See IMS Event Templates documentation for creating custom event templates.
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— select the output seismogram duration

— choose whether the exported data stream should be re-sampled? to be phase-aligned
with ATU (GPS)

— choose the sites you wish to export

File Edit Event Data Processing Tools Window Help
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Figure 6: Exporting continuous data in Trace.

e To export a time range of less than one day (the database’s default time resolution display),
ensure the PER_HOUR display is enabled on the database:

— right click on the database and select the Properties menu item

— in the Tools tab select PER_HOUR for the Day Display parameter

¢ Note: if large amounts of data are exported (sampling rates > 6000 sps) you should allocate
more system memory to Trace (4 GB recommended), or else the export may not complete.
To increase Trace memory allocation:

— open the Tools > Options menu

— navigate to the Miscellaneous > Application tab

3Re-sampling is done using bandlimited interpolation, implemented using a windowed sinc method.
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— edit the Maximum Heap Size [MB] setting and change to 4096

— close Trace; Trace will automatically restart, make sure you close Trace again and that
it does not auto-restart before launching Trace from in the usual way (“cold-starting”
from the command line or double clicking the desktop icon)
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Change Control Record

|

Date Author | Description Revision
2013/03/07 | AVZ | Original document 0
2018/05/22 | AVZ | Minor changes and converted source to LyX 1
2018/08/03 | GG | Rewrite to include updates for changes to Trace 2

(including Trace-Standalone, new seismogram
importer and post-associator, continuous
phase-locked ASCII exporter)

2018/08/07 | GG | Correct errors in text 3
Some clarifications and additions including
images/screenshots

2018/08/10 | GG | Note about keeping configs synchronised on 4
Trace computer

Table 1: Change record
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